Compiling Devcoin

Debian 7 (Wheezy), Linux Mint 17 (Qiana) and Ubuntu 14.04 (Trusty)

devcoind

We need to install libdb4.8-dev and libdb4.8++-dev. To do this we'll reach back into the Debian 6 (Squeeze) repository. Create a file to point to the Squeeze repo:

sudo vi /etc/apt/sources.list.d/debian-squeeze.list

And enter the following line into the text file and save it:

deb http://ftp.us.debian.org/debian/ squeeze main

Update your repository listings:

sudo apt-get update

And get any package upgrades:

sudo apt-get upgrade

Install the dependencies:

sudo apt-get install libdb4.8-dev libdb4.8++-dev build-essential libboost-all-dev git

Check out the correct git branch:

git clone --depth=1 https://github.com/coinzen/devcoin.git
cd devcoin

Build devcoind:

cd src
make -f makefile.unix USE_UPNP=-

devcoin-qt

Assumimg you've installed the dependencies for devcoind, install the dependencies:

sudo apt-get install libminiupnpc-dev libqrencode-dev qt4-qmake libqt4-dev

Build devcoin-qt:

cd ~/devcoin
qmake USE_UPNP=0 USE_DBUS=1 USE_QRCODE=1
make

QR Code
QR Code compiling_devcoin (generated for current page)