DEVTOME.COM HOSTING COSTS HAVE BEGUN TO EXCEED 115$ MONTHLY. THE ADMINISTRATION IS NO LONGER ABLE TO HANDLE THE COST WITHOUT ASSISTANCE DUE TO THE RISING COST. THIS HAS BEEN OCCURRING FOR ALMOST A YEAR, BUT WE HAVE BEEN HANDLING IT FROM OUR OWN POCKETS. HOWEVER, WITH LITERALLY NO DONATIONS FOR THE PAST 2+ YEARS IT HAS DEPLETED THE BUDGET IN SHORT ORDER WITH THE INCREASE IN ACTIVITY ON THE SITE IN THE PAST 6 MONTHS. OUR CPU USAGE HAS BECOME TOO HIGH TO REMAIN ON A REASONABLE COSTING PLAN THAT WE COULD MAINTAIN. IF YOU WOULD LIKE TO SUPPORT THE DEVTOME PROJECT AND KEEP THE SITE UP/ALIVE PLEASE DONATE (EVEN IF ITS A SATOSHI) TO OUR DEVCOIN 1M4PCuMXvpWX6LHPkBEf3LJ2z1boZv4EQa OR OUR BTC WALLET 16eqEcqfw4zHUh2znvMcmRzGVwCn7CJLxR TO ALLOW US TO AFFORD THE HOSTING.

THE DEVCOIN AND DEVTOME PROJECTS ARE BOTH VERY IMPORTANT TO THE COMMUNITY. PLEASE CONTRIBUTE TO ITS FURTHER SUCCESS FOR ANOTHER 5 OR MORE YEARS!

Table of Contents

This tutorial is a subset of the Unix build read-me for devcoin found here . If you have problems with this tutorial please refer to the Unix read-me for more detailed steps on how to build devcoind/devcoin-qt.

devcoind

Update your repository listings:

Upgrade openssl to fix heartbleed bug:

sudo apt-get install openssl

Install any libcurl dependencies:

sudo apt-get build-dep curl

Install devcoind dependencies:

sudo apt-get install libtool libssl-dev pkg-config build-essential libboost-all-dev git

for Ubuntu 13.10: libboost1.54 will not work, remove libboost1.54-all-dev and install libboost1.53-all-dev instead.

Install LibDB4.8:

It is recommended to remove any libdb version's other than 4.8. Some version's of Ubuntu come with newer version's of libdb4.8, although libdb5.3 should be ok we still recommend to use libdb4.8 as that is what we used to test and pass the quality verification of the devcoin core sourcecode. By doing one of these methods, you will be asked to remove the current libdb version, if it is not 4.8 we recommend doing so. Choose the method that best suits you. If one doesn't work you can use the next one down the list.

Method 1:

db4.8 packages are available here. You can add the repository using the following command:

sudo add-apt-repository ppa:bitcoin/bitcoin
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libdb4.8-dev libdb4.8++-dev

Method 2: The oldstable repository contains db4.8 packages.

Open your sources.list to add the package from an official debian repository:

sudo vi /etc/apt/sources.list

And enter the following line into the text file and save it:

deb http://ftp.us.debian.org/debian/ oldstable main

To enable the change run

sudo apt-get update

And get any package upgrades:

sudo apt-get upgrade

Install:

sudo apt-get install libdb4.8-dev libdb4.8++-dev

Method 3: we can reach back into the Debian 6 (Squeeze) repository. Create a file to point to the Squeeze repo:

sudo vi /etc/apt/sources.list.d/debian-squeeze.list

And enter the following line into the text file and save it:

deb http://ftp.us.debian.org/debian/ squeeze main

To enable the change run

sudo apt-get update

And get any package upgrades:

sudo apt-get upgrade

Install:

sudo apt-get install libdb4.8-dev libdb4.8++-dev

Great you have installed all of the dependencies, now check out the correct devcoin sourcecode git branch:

git clone --depth=1 https://github.com/coinzen/devcoin.git
cd devcoin

Build devcoind:

cd src
make -f makefile.unix clean
make -f makefile.unix USE_UPNP=-
strip devcoind

Run with console print statements:

run: ./devcoind -printtoconsole

devcoin-qt

Assuming you've installed the dependencies for devcoind and built devcoind already, install the dependencies for qt:

sudo apt-get install libminiupnpc-dev libpng-dev libqrencode-dev qt4-qmake libqt4-dev

Build devcoin-qt:

cd ~/devcoin
qmake USE_UPNP=0 USE_DBUS=1 USE_QRCODE=1
make

Run:

./devcoin-qt

QR Code
QR Code compiling_devcoin_with_ubuntu (generated for current page)
 

Advertise with Anonymous Ads